Custom snapshot time-out


#1

Just installed Vertical Backup on a new host and am receiving snapshot time-outs:

2018-10-25 00:10:04.843830 TRACE COMMAND_RUN Running command: /bin/vim-cmd vmsvc/snapshot.create 1 2018-10-25-00-10-04 'Created by Vertical Backup 1.2.1' 0 1
2018-10-25 00:20:04.854199 INFO COMMAND_RUN Command '/bin/vim-cmd vmsvc/snapshot.create 1 2018-10-25-00-10-04 'Created by Vertical Backup 1.2.1' 0 1' times out
2018-10-25 00:20:04.863912 INFO COMMAND_OUTPUT Create Snapshot:
2018-10-25 00:20:04.864087 ERROR COMMAND_RUN Command '/bin/vim-cmd vmsvc/snapshot.create 1 2018-10-25-00-10-04 'Created by Vertical Backup 1.2.1' 0 1' returned -9

This isn’t a problem with Vertical Backup per se - normal, quiesced snapshots taken manually via vSphere Client do indeed take quite an unusually long time, and it’s something I obviously need to investigate further (it’s a bloated SBS 2011 server and the plan is to offload a bunch of applications and databases onto a dedicated VM).

But they do complete - in around 12 minutes. Which unfortunately, is 2 minutes longer than VBs hard-coded time-out of 10 minutes, if I understand correctly?

Would it be possible to allow a custom time-out via a switch? Meanwhile, I’ve managed to complete the initial backup with --no-quiesce.

A custom time-out would allow us to buy some time to get to the bottom of why snapshots are taking so long, in case updating the ESXi host and VMWare Tools over the weekend doesn’t help initially. (RAM usage is being looked at as well. But those databases may take a while to get moved off there…)


#2

The new version 1.2.2 at http://acrosync.com/esxi/vertical now supports a --snapshot-timeout option. For example, this will increase the timeout to 1200 seconds:

./vertical backup vm-test --snapshot-timeout 1200

#3

Excellent, thank you - that done the job nicely.