Backblaze - Authorization failure


#1

I am receiving an “Authorization failure” error when initializing Backblaze storage while using the application key created for Vertical. However, if I use the master application key, it works.


#2

I just uploaded a new 1.2.2 build to http://acrosync.com/esxi/vertical which should be able to connect using application keys.


#3

Still failing for me even with the new build.


#4

Can you post the results of vertical -vv init ... or `verti here? Also, please make sure that you’re running the latest build (sha256: bbfdba7897b6b84ca000687e8703d281b2c058f5410d832d7e8c757532a1941c) and that the master key works.


#5

Sure thing! Logs below. First I tried the application key. Second (and successful) attempt after the 401 was the master key. sha256 sum included for good measure. Removed some stuff to protect the identities of the innocent :slight_smile:

[root@<snip>/verticalbackup] ./vertical -vv init backupName <bucket>
Vertical Backup 1.2.2
Running init command -- chunk size: 1048576, encrypt: False, temporary directory: None
Attempting to read from environment variable VB_B2_ACCOUNT
Enter the B2 account id:<accountId>
Attempting to read from environment variable VB_B2_KEY
Enter the B2 application key:<applicationKey>
URL request https://api.backblazeb2.com/b2api/v1/b2_authorize_account returned status code 401
[root@<snip>/verticalbackup] ./vertical -vv init backupName <bucket>
Vertical Backup 1.2.2
Running init command -- chunk size: 1048576, encrypt: False, temporary directory: None
Attempting to read from environment variable VB_B2_ACCOUNT
Enter the B2 account id:<accountId>
Attempting to read from environment variable VB_B2_KEY
Enter the B2 application key:<masterKey>
Authorization succeeded
Storage set to b2://<bucket>
Initialized the storage with a chunk size of 1048576
Preference has been saved to /<snip>/verticalbackup/.verticalbackup/preferences
[root@<snip>/verticalbackup] sha256sum vertical
bbfdba7897b6b84ca000687e8703d281b2c058f5410d832d7e8c757532a1941c  vertical

#6

Did you enter the application key id when it asked for the B2 account id? The prompt is misleading here – it should have stated that the application key id is needed instead of the account id when you’re not using the master key.


#7

Oh… no I didn’t! I was still entering the account ID.

I re-ran the init and everything worked with that piece of advice! Would be great to have the docs updated for that because the next time I need to set this up I will likely forget that! Thank you!