Certificate verify failed for Minio TLS

I am changing the backup destination to a Minio TLS bucket. The Minio server has a new Lets Encrypt certificate on it.

When doing an init on the new storage with minios:// as the URL I get this error below. I tried setting REQUESTS_CA_BUNDLE but that didnt work, then I realized with the print stack option that it is using Boto for this.

Failed to connect to the bucket /verticalbackup: SSLError(1, u’[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:661)’)
Traceback (most recent call last):
File “vertical_s3storage.py”, line 65, in getBucket
File “site-packages/boto/s3/bucket.py”, line 473, in get_all_keys
File “site-packages/boto/s3/bucket.py”, line 399, in _get_all
File “site-packages/boto/s3/connection.py”, line 668, in make_request
File “site-packages/boto/connection.py”, line 1071, in make_request
File “site-packages/boto/connection.py”, line 1030, in _mexe
SSLError: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:661)

I tried setting env variable AWS_CA_BUNDLE to the path to the newest CAcert.pem file from https://curl.se/docs/caextract.html but that didnt work either.

Is there a way to set a CA bundle that would work for Minio TLS? Or could Vertical Backup be changed to use a cacert.pem file that is in the same folder its running from?

Thank you