Https support for minio storage urls


#1

Are there any plans to support https on minio storage urls?

I have minio (S3) setup on a new freenas server using our wildcard ssl certificate. Trying to init the storage I get the following message:

Failed to connect to the bucket /verticalbackup: Client sent an HTTP request to an HTTPS server.


#2

This was supposed to work but the ssl flag wasn’t set correctly. I uploaded a new version 1.4.1 to https://acrosync.com/esxi/vertical which should fix this bug.


#3

Still seems to be giving the error.

./vertical -v init myesxi minio://freenas.example.com:9000/verticalbackup
Vertical Backup 1.4.1
Running init command – chunk size: 1048576, encrypt: False, temporary directory: None
Enter the S3 access id:redacted
Enter the S3 secret key:redacted
Failed to connect to the bucket /verticalbackup: Client sent an HTTP request to an HTTPS server.


#4

Can you use port 443? HTTPS is only enabled when the port is 443.

I can add an option to enable HTTPS regardless explicitly. For instance, we can use minios:// instead of minio://.


#5

minios:// would probably work better. I have a few other applications using the freenas minio blockstore at port 9000 so I’d have to change them. I’d also have to move it to a different IP so it didn’t conflict with the freenas web console on 443.


#6

Version 1.4.2 at https://acrosync.com/esxi/vertical now accepts minios://for HTTPS support.


#7

Awesome! I did have to add my ca-bundle to the freenas minio cert as it was giving an error.

Failed to connect to the bucket /verticalbackup: SSLError(1, u’[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:661)’)

But once that was added it worked great. Thanks!